Thursday, February 1, 2007

Cisco Certified Network Associate Exam Curriculum

Before starting any plan for ccna examination or on any exams, we must know the requirement for the exam, or the syllabus of the exam. Therefore, again, I will highlight the content of the curriculum for you all to follow.

The following information provides general guidelines for the content likely to be included on the exam. However, other related topics may also appear on any specific delivery of the exam.

In order to better reflect the contents of the exam and for clarity purposes the guidelines below may change at any time without notice.

Planning & Designing

  • Design a simple LAN using Cisco Technology
  • Design an IP addressing scheme to meet design requirements
  • Select an appropriate routing protocol based on user requirements
  • Design a simple internetwork using Cisco technology
  • Develop an access list to meet user specifications
  • Choose WAN services to meet customer requirements

Implementation & Operation

  • Configure routing protocols given user requirements
  • Configure IP addresses, subnet masks, and gateway addresses on routers and hosts
  • Configure a router for additional administrative functionality
  • Configure a switch with VLANS and inter-switch communication
  • Implement a LAN
  • Customize a switch configuration to meet specified network requirements
  • Manage system image and device configuration files
  • Perform an initial configuration on a router
  • Perform an initial configuration on a switch
  • Implement access lists
  • Implement simple WAN protocols


  • Utilize the OSI model as a guide for systematic network troubleshooting
  • Perform LAN and VLAN troubleshooting
  • Troubleshoot routing protocols
  • Troubleshoot IP addressing and host configuration
  • Troubleshoot a device as part of a working network
  • Troubleshoot an access list
  • Perform simple WAN troubleshooting


  • Describe network communications using layered models
  • Describe the Spanning Tree process
  • Compare and contrast key characteristics of LAN environments
  • Evaluate the characteristics of routing protocols
  • Evaluate TCP/IP communication process and its associated protocols
  • Describe the components of network devices
  • Evaluate rules for packet control
  • Evaluate key characteristics of WANs
Taken from CISCO Systems Webpage

Tuesday, January 30, 2007

What 's VTP ?

VLAN Trunk Protocol (VTP) reduces administration in a switched network. When you configure a new VLAN on one VTP server, the VLAN is distributed through all switches in the domain. This reduces the need to configure the same VLAN everywhere. VTP is a Cisco-proprietary protocol that is available on most of the Cisco Catalyst series products.

Note: This document does not cover VTP Version 3. VTP Version 3 differs from VTP Version 1 (V1) and Version 2 (V2), and it is only available on Catalyst OS (CatOS) 8.1(1) or later. VTP Version 3 incorporates many changes from VTP V1 and V2. Make certain that you understand the differences between VTP Version 3 and prior versions before you alter your network configuration.

Refer to one of these sections of the document Configuring VTP for more information:

For more details, you may go to CISCO doc

Courtesy from CISCO Systems Page

Where can we register the Exam?

Dear all,

I'm realize that before we go to CCNA, we need to register the exam. For CCNA exam, we have PEARSON VUE and PROMETRIC as the test center.

Both VUE and PROMETRIC offer the same set of questions regardless of your location on the globe.More or less the testing centers received same routing updates from cisco as they are adjacent.

Click below link for more CISCO's Learning Partner System

Steps To Study Ccna

Dear Friends,

Below are the steps in preparing for CCNA Exam.

Follow the steps below:

1) You have two options read CCNA INTRO BOOK and ICND book (Cisco Press) or Read CCNA SYBEX BOOK(Todd Lammle).
Note: If you are reading for example SYBEX book and any topic which is not clear you can refer cisco press books for those topics and vice versa. Also which ever book you follow must solve practice questions at the end of other books too.

2) If you want to follow one book you can go for CCNA SYBEX Book (Todd Lammle).

3) When you study the chapter must solve the questions in the end too.

4) Do labs along with chapters. I would recommend you to do labs on real equipment which will give you more confidence and help in real life scenario's if not then do labs on simulators.

5) Till the time you are reading book, solving questions and performing labs do not consult any
practice exams or test like test king or actual test etc.

6) Once you are done with book and labs only then solve test king and/or actual test make sure if you find any mistake in them consult book again.

7) Register for CCNA exam at least 7 days before you have prepared for the exams.

Yoshh...go for it man!!!..Be certified...

Based on Makecrazy experience at Sadhikov Forum

Ccna Commands In 10mins

Hi Friends,

After finishing my CCNA exams last year. I 'm still finding materials to enhance my configuring switches capabilities. If we know the necessary commands to configure the machine, it will help us to complete the work.


#sh ip route - To view IP routing tables created on a Cisco router.

-Static Routing- Routers are manually configured for networks that are not directly connected, to be able to route to all networks via the next-hop interface.

Example- Let be the IP of a network not directly connected
Let be the next hop interface

(config)#ip route

-to remove static route
(config)#no ip route

-Default Routing- Used on stub networks only to send packets with remote destination network not in the routing table to the next hop router.

(Assume IP is not in routing table)

-first remove static route
(config)#no ip route
(config)#ip route

-RIP-A distance vector routing protocol that passes complete routing table contents to neighbouring routers

Example- Let & be directly connected networks of a router interfaces and be non-directly connected

-first delete all static routes
(config)#no ip route
(config)#router rip

-Verifying RIP
1.Sh ip route
2.debug ip

-Holding Down RIP Propagation-To stop RIP update sending but allow its receipt
-say for s0/0 with ip

(config)#router rip
(config-router)#passive-interface serial 0/0

-IGRP-Also a distance routing protocol
Example- Let & be directly connected networks of a router interfaces with autonomous system number of 10 and be non-directly connected

#router igrp 10

-Verifying IGRP ip route protocols- Displays routed protocols and their interfaces ip protocols- Displays routing protocols configured
4.debug igrp events- Displays summary of IGRP routing information running on the network
5.debug igrp transactions- Displays messages request from neighbour routers

-Turning off all possible debugging
#un all

-EIGRP-Uses classless routing which is subnet mask information sent with routing protocol updates.

Example- Let & be directly connected networks of a router interfaces with autonomous system number of 20 and be non-directly connected

#router eigrp 20

-To stop EIGRP from working on an interface-no sending no receipt
(config)#router eigrp 20
(config-router)#passive-interface serial 0/0

-To enable EIGRP on discontiguos networks(two different subnetworks of classfull network connected by another different classful subnetwork)
Example- Let & be directly connected to a router to another remote subnetwork of, then to enable EIGRP, we use

(config)#router eigrp 100
(config-router)#no auto-summary
N.B-The no auto-summary command sholuld be enabled in routers that encloses such networks.

-Verifying EIGRP
1. sh ip route- Shows entire routing table
2. sh ip route eigrp- Shows only EIGRP entries in the routing table
3. ip eigrp neighbours- Shows all EIGRP neighbours
4. ip eigrp topology- Shows entries in the EIGRP topology table

OSPF- A link-state routing protocol

Example- Let be the network directly connected to the router upon which OSPF is to be enabled; with ospf ID of 1 and area o

(config)#router ospf 1
(config-router)#network area0

-Loopback Interface- They are configured to be used as the routers RID to advertise the routes and elect DR and BDR.

Example- Let the loopback iinterface be configured on interface with ip

(config)#int loopback 0
(config-if)#ip address
(config-if)#no shut

-Verifying OSPF Configuration
1. sho ip ospf- Used to display all OSPF information
2. sho ip ospf database- indicates the number of links and neighboring router ID
3. sho ip ospf interface- Displays all OSPF interface related info
4. sho ip ospf neighbour- Summarizes OSPF info about neighbours
5. sho ip protocols- Overview of all present running protocols

- Verifying Loopback and RID
1. sho running-config- To verify loopback address
2. sho ip ospf database- Verifies the new RID of each router
3. sho ip ospf interface- Verifies the new RID of each router

-Initial configuration of a 1900 Switch with ip

#config t
(config)#enable password level 1 kennifeh
(config)#enable password level 15kennifeh 1
(config)#enable secret kennifeh 2(when enabled no need 4 enable password)
(config)#hostname kenn 1900
(config)#ip address
(config)#ip default-gateway
(config)#int f0/1
(config-if)#description Finance_vlan (No space for 1900)
(config-if)#int f0/26
(config-if)#description Trunk_to_Biulding

-Initial Configuration of 2950 Switch with ip

#config t
(config)#hostame kenn2950
(config)#enable password kenn
(config)#enable password kenn1(enable and enable secret password must be different)
(config)#line vty 0 15
(config-line)#password telnet
(config-line)#line con 0
(config-line)#password console
(config)#int vlan 1
(config-if)#ip address
(config-if)#no shut
(config-if)#int f0/1
(config-if)#description sales printer(with space)
(config-if)#int f0/12
(config-if)description connection to backbone
(config)#ip default-gateway

-Erasing Switching Configuration 1900

#delete nvram

-Erasing Switching Configuration 2950

#erase startup-config

-Configuring VLANS 1900

#config t
(config)#vlan 2 name Cisco
(config)#vlan 3 name Microsoft
(config)#vlan 4 name Comptia

verify with command sh run

-Configuring for 2950

#vlan database
(vlan)#vlan 2 name Cisco
(vlan)#vlan 3 name Microsoft
(vlan)#vlan 4 name Comptia

verify with command sh vlan brief

-Assigning Switch Ports To Vlan-1900

(config)#int e0/2
(config-if)#vlan-membership static 2
(config-if)#int e0/3
(config-if)#vlan-membership static 3

verify with sh vlan

-Assigning Switch Ports To Vlan-2950

(config)#int f0/2
(config-if)#switchport access vlan 2
(config-if)#int f0/3
(config-t)#switchport access vlan 3
(config-if)#int f0/4
(config-if)#switchport access vlan 4

verify with sh vlan brief

-Configuring Trunks ports

(config)#int f0/26
(config-if)#trunk on

-Configuring Trunk Ports for 2950

(config)#int f0/12
(config-if)#switchport mode trunk

-To disable Trunk

use- switchport mode access

-To verify Trunking

use sh running config

-Configuring Inter-vlan Routing for 1900 connecting to 2600

(config)#int f0/0.1
(config-if)#encapsulation isl vlan (d number)

-Configuring Inter-vlan Routing for 2950 connecting to 2600

(config)#int f0/0.1
(config-if)#encapsulation dot1q vlan (d number)

-Configuring VTP for 1900

(config)#vtp server
(config)vtp domain kenn
(config)#vtp password kenn

-Configuring VTP for 2950

(config)#vtp mode server
(config)#vtp domain routersim

-verify with sh vtp status

show vtp status

-Checking the Current Configuration Register Values

show version or show ver

-Changing Configuration Register

(config)#config-register 0x101 (d default is 0x2102)

-Recovering Passwords

-1. Interrupt the Router Boot Sequene
ctrl+Break key (windows wont perform break key, only 95/98)

-2. Changing the configuration register
-for 2600 series router
rammon>confreg 0x2142

-for 2500
type 0 after a break and enter the command o/r 0x2142

-3. Reloading the Router and Entering Privilged mode
-for 2600-type reset
-for 2500-type I

-4. Viewing and changing the configuration
-copy run start

-5. Resetting the configuration Register and Reloading the Router
-config t
-config-register 0x2102
-copy run start-to save

-Backing up and restoring the Cisco ios

-1. verifying flash memory-Ensuring flash memory has enough room
router#sh flash

-2. Backing-up the ciso ios
first verify server connectivity by- Router#ping
then; router#copy flash tftp
-3. Restoring or upgrading the cisco router ios
router#copy tftp flash

-Backing up and Restoring the Cisco configuration

1.Backing up the cisco router configuration
-copy runing config tftp

2. verifying the current configuration
-sh run

3. copying the current cofiguration to NVRAM
-copy run start

4. copying the current configuration to a TFTP server
-copy run TFTP

5. Restoring the Cisco Router Configuration
-copy TFTP run

6. Erasing the configuration
-erase startup-config

-Getting CDP timers and Holdtime information

Router#config t
Router(config)#cdp timer 90
Router(config)#cdp holdtime 240

-To turn-off CDP Completely

no cdp run

-Gathering Neighbour information

kenn2509#sh cdp nei- delivers information about directly connected devices
OR kenn2509#sh cdp neighbour detail Also sh cdp entry

-Gathering Interface Traffic Information
kenn2509#sh cdp traffic

-Gathering port and Interface information

kenn2509#sh cdp interface

-To turn off cdp on a router, use

no cdp enable then ^z

-Using Telnet


-Telnetting into multiple devices simultaneously

then, 2501B>{cntl+shift+6, then x}

-checking Telnet connections

kenn2509#sh sessions-connections from your router to remote

-checking Telnet users

kenn2509#sh user

-closing Telnet sessions

1900switch>exit OR
kenn2509#disconnect1 (num of active networks)

-Resolving Hostname

kenn2509#config t
kenn2509(config)#ip host 2501B
kenn2509(config)#ip host 1900switch

-To remove a hostname from a table, use

RouterA(config)#no ip host routerB

-Using DNS to resolve names

#config t
(config)#ip domain-lookup (usually turned on by default)
(config)#ip name-server (ip of an assumed DNS set)
(config)#ip domain-name (Appends the domain name to a host)

-Check Network Connectivity
use ping command
#ping kenn2509

-Using Traceroute command
#trace 2501B

-Creating a Standard Access Lists (1-99 or 1,300-1,999)

(config)#access-list 10 deny (using the ip as a test)

-Controlling vty(Telnet) sessions

(config)#access-list 50 permit
(config)#line vty 0 4
(config-line)#access-class 50 in

-Creating Extended Access-lists (100 to 199) OR (2000 to 2699)

(config)#access-list 110 deny tcp any host eq 23 log
(config)#access-list 110 permit ip any any
(config)#int f0/0
(config-if)#ip access-group 110 in
(config-if)#ip access-group 110 out

Thanks for kennifeh@sadhikov forum for the tips

Router Summarizing In 5 Mins

Ripv1 and IGRP

Those protocols do auto summary to the classfull network which means
if you try to add a network of it will auto summary to

You cant turn off this auto summary in Ripv1 and IGRP

you can turn it off on Ripv2 and EIGRP summarizing

OSPF and IS IS does not auto summery

Classful routing protocols (RIPv1 and IGRP) automatically summarize routes on the classful network boundary and do not support summarization on any other bit boundaries. Classless routing protocols support summarization on any bit boundary.

Route Summarization Calculation example

suppose you got this networks attached to your router like different LAns

1) first step:
You will convert everything to binary

10101100.00010000.00001100.00000000 -->
10101100.00010000.00001101.00000000 --->
10101100.00010000.00001110.00000000 -->
10101100.00010000.00001111.00000000 -->

2) Second Step

You need to locate the bits till where the bits are equals
What i mean with this ?

10101100.00010000.00001100.00000000 -->
10101100.00010000.00001101.00000000 --->
10101100.00010000.00001110.00000000 -->
10101100.00010000.00001111.00000000 -->

As you can see all the bits are equal till 6th bit of the 3rd octet(can you can see it above i BOLDED all the equals bits)

Now you find this we will go to step 3

3)Third step

You need to count those bits, the summary route number will be the first IP address in the block, and the subnet mask will be the number of common bits.

so the answer is

Well i think this is all you need to know about summarizing If anyone find any mistake on my explanation they are welcome but im pretty sure its like this.

thanks for NightShake@sadhikov for the information :-)

Connectinng Two Different Switches

Here...again, I will continue to show you how to configure the access type switch, Cisco Catalyst 2950 with Avaya Multiservice Switch(Layer 2) from my experience.

We 'll configure the SX port to discard vlan(4097). This vlan is used to carry multiple vlan in a trunk. We add 802.1Q as the encapsulation mode for the port.
The configuration for the Avaya switch as in below line;

set port name 6/4 "Port 6.4 (Block E)"
set port vlan 6/4 4097
set port trunking-format 6/4 ieee-802.1Q
set port spanning-tree-mode 6/4 disable
set port vlan-binding-method 6/4 bind-to-all

To know more about the product of Avaya Multiservice Switches, you may go to to link.


Next, we will configure the SX gigabit module in the switch to accommodate the multiple vlan requirement for the port.

The configuration for the Cisco switch as in below line;

interface GigabitEthernet0/2
switchport mode trunk
speed nonegotiate
storm-control broadcast level 60.00

To know more about the Cisco Catalyst 2950 configuration, you may go to to link.

Before ending this process, we must do the necessar troubleshooting procedure such as ping, tracert and so on to make sure there is a connectivity between the switches.

That'all for for this topic..Thanks